summaryrefslogtreecommitdiff
path: root/config/matrix.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2022-12-01 08:54:17 -0500
committerKjetil Orbekk <kj@orbekk.com>2022-12-01 08:54:17 -0500
commita0ea66ddc749e42aaea89eb6b27887e4fe32ad45 (patch)
tree9af5342611be47ff6b6c65210553c45e532495f9 /config/matrix.nix
parentb5efaa433c1c6f53413b0443a18c1aea95bd2215 (diff)
Fix formatting
Diffstat (limited to 'config/matrix.nix')
-rw-r--r--config/matrix.nix49
1 files changed, 26 insertions, 23 deletions
diff --git a/config/matrix.nix b/config/matrix.nix
index 6a57e76..8747d62 100644
--- a/config/matrix.nix
+++ b/config/matrix.nix
@@ -1,9 +1,9 @@
{ config, lib, pkgs, ... }:
let
matrixPort = (import ../data/aliases.nix).services.matrix.port;
- matrixFederationPort = (import ../data/aliases.nix).services.matrixFederation.port;
-in
-{
+ matrixFederationPort =
+ (import ../data/aliases.nix).services.matrixFederation.port;
+in {
networking.firewall.allowedTCPPorts = [ matrixPort matrixFederationPort ];
services.matrix-synapse = {
@@ -11,27 +11,30 @@ in
server_name = "orbekk.com";
# registration_shared_secret = "disable_after_registration";
listeners = [
- {
- port = matrixPort;
- bind_address = "";
- type = "http";
- tls = false;
- x_forwarded = true;
- resources = [
- { names = ["client" "webclient"]; compress = true; }
+ {
+ port = matrixPort;
+ bind_address = "";
+ type = "http";
+ tls = false;
+ x_forwarded = true;
+ resources = [{
+ names = [ "client" "webclient" ];
+ compress = true;
+ }
# { names = ["federation"]; compress = false; }
- ];
- }
- {
- port = matrixFederationPort;
- bind_address = "";
- type = "http";
- tls = true;
- x_forwarded = false;
- resources = [
- { names = ["federation"]; compress = false; }
- ];
- }
+ ];
+ }
+ {
+ port = matrixFederationPort;
+ bind_address = "";
+ type = "http";
+ tls = true;
+ x_forwarded = false;
+ resources = [{
+ names = [ "federation" ];
+ compress = false;
+ }];
+ }
];
};
}