summaryrefslogtreecommitdiff
path: root/config/laptop.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2020-11-02 21:21:16 -0500
committerKjetil Orbekk <kj@orbekk.com>2020-11-07 11:25:47 -0500
commit63dd883c934fc07789f3a1f0b485471534050e0d (patch)
tree1ea76fb3f2e3e9db06568a60ff6965ebd128faab /config/laptop.nix
parent4fa2a83b0e8cc48da0a55b16c856b72bacd37f67 (diff)
Add desktop packages
Diffstat (limited to 'config/laptop.nix')
-rw-r--r--config/laptop.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/config/laptop.nix b/config/laptop.nix
new file mode 100644
index 0000000..230d513
--- /dev/null
+++ b/config/laptop.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+{
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ # systemd-boot.memtest86.enable = true;
+ timeout = 0;
+ efi.canTouchEfiVariables = true;
+ };
+ };
+
+ networking = {
+ networkmanager.enable = lib.mkDefault true;
+ firewall.enable = lib.mkDefault true;
+ };
+
+};
+
+
+}