summaryrefslogtreecommitdiff
path: root/config/hydra.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2022-12-01 08:46:14 -0500
committerKjetil Orbekk <kj@orbekk.com>2022-12-01 08:46:14 -0500
commitb5efaa433c1c6f53413b0443a18c1aea95bd2215 (patch)
treea33278d68cb11db5218d5f77b2dd4843f5050caa /config/hydra.nix
parent0a15752e6d5d0ab291afecf6cb2baf75c045167d (diff)
Update nixos
Diffstat (limited to 'config/hydra.nix')
-rw-r--r--config/hydra.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/config/hydra.nix b/config/hydra.nix
index cb9c8e6..5ebc605 100644
--- a/config/hydra.nix
+++ b/config/hydra.nix
@@ -1,8 +1,6 @@
{ config, lib, pkgs, ... }:
-let
- hydraPort = (import ../data/aliases.nix).services.hydra.port;
-in
-{
+let hydraPort = (import ../data/aliases.nix).services.hydra.port;
+in {
networking.firewall.allowedTCPPorts = [ hydraPort ];
virtualisation.virtualbox.host.enable = true;
@@ -11,7 +9,7 @@ in
enable = true;
hydraURL = "https://hydra.orbekk.com";
notificationSender = "kj+hydra@orbekk.com";
- buildMachinesFiles = [];
+ buildMachinesFiles = [ ];
useSubstitutes = true;
port = hydraPort;
extraConfig = ''
@@ -40,24 +38,20 @@ in
touch /opt/secret/hydra_key/initialized
fi
'';
- };
+ };
nix = {
distributedBuilds = true;
nrBuildUsers = 30;
# Enable this if I run low on disk.
gc.automatic = lib.mkForce false;
- buildMachines = [
- {
- hostName = "localhost";
- systems = [ "x86_64-linux" "i686-linux" ];
- maxJobs = "16";
- supportedFeatures = [ "kvm" "nixos-test" "big-parallel" "benchmark" ];
- }
- ];
+ buildMachines = [{
+ hostName = "localhost";
+ systems = [ "x86_64-linux" "i686-linux" ];
+ maxJobs = "16";
+ supportedFeatures = [ "kvm" "nixos-test" "big-parallel" "benchmark" ];
+ }];
extraOptions = "auto-optimise-store = true";
};
- nixpkgs.config = {
- allowUnfree = true;
- };
+ nixpkgs.config = { allowUnfree = true; };
}