summaryrefslogtreecommitdiff
path: root/config/dns.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2022-12-01 08:46:14 -0500
committerKjetil Orbekk <kj@orbekk.com>2022-12-01 08:46:14 -0500
commitb5efaa433c1c6f53413b0443a18c1aea95bd2215 (patch)
treea33278d68cb11db5218d5f77b2dd4843f5050caa /config/dns.nix
parent0a15752e6d5d0ab291afecf6cb2baf75c045167d (diff)
Update nixos
Diffstat (limited to 'config/dns.nix')
-rw-r--r--config/dns.nix17
1 files changed, 4 insertions, 13 deletions
diff --git a/config/dns.nix b/config/dns.nix
index d0e67c0..c1172ef 100644
--- a/config/dns.nix
+++ b/config/dns.nix
@@ -4,8 +4,7 @@
let
masterZones = [ "tommvo.com" "orbekk.com" "orbekk.no" ];
zone-files = pkgs.callPackage ../pkgs/zone-files/default.nix { };
-in
-{
+in {
networking.firewall = {
allowedTCPPorts = [ 53 ];
allowedUDPPorts = [ 53 ];
@@ -13,17 +12,9 @@ in
services.bind = {
enable = true;
- forwarders = [
- "1.1.1.1"
- "1.0.0.1"
- "2606:4700:4700::1111"
- "2606:4700:4700::1001"
- ];
- cacheNetworks = [
- "::1/128"
- "127.0.0.0/24"
- "10.0.0.0/8"
- ];
+ forwarders =
+ [ "1.1.1.1" "1.0.0.1" "2606:4700:4700::1111" "2606:4700:4700::1001" ];
+ cacheNetworks = [ "::1/128" "127.0.0.0/24" "10.0.0.0/8" ];
extraOptions = ''
serial-update-method unixtime;
listen-on-v6 { 2001:470:8e2e:20::d; };