summaryrefslogtreecommitdiff
path: root/config/common.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-13 10:41:48 -0400
committerKjetil Orbekk <kjetil.orbekk@gmail.com>2017-05-13 10:41:48 -0400
commit9b0220f68fa95b8f2b1d6d3ee3466798a134f57e (patch)
treedfc7c89341976113345e42e013bd3dad28359b5a /config/common.nix
parent5ffdf367cdf06666e45973d6aeb3862289b27334 (diff)
Add refactored nixos configuration for laptop pincer.
Diffstat (limited to 'config/common.nix')
-rw-r--r--config/common.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/config/common.nix b/config/common.nix
new file mode 100644
index 0000000..b23619a
--- /dev/null
+++ b/config/common.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+{
+ site = {
+ ports = {
+ };
+ };
+
+ programs.fish.enable = true;
+
+ environment.shellAliases = {
+ vim = "nvim";
+ };
+ environment.systemPackages = with pkgs; [
+ dnsutils
+ gnupg
+ haskellPackages.hledger
+ mosh
+ neovim
+ nix-repl
+ nox
+ silver-searcher
+ whois
+ ];
+ time.timeZone = "America/New_York";
+
+ nix = {
+ useSandbox = true;
+ maxJobs = 8;
+ buildCores = 0; # auto configure
+ };
+
+ boot.cleanTmpDir = true;
+}