summaryrefslogtreecommitdiff
path: root/config/common.nix
diff options
context:
space:
mode:
authorKjetil Orbekk <kj@orbekk.com>2021-03-07 15:11:56 -0500
committerKjetil Orbekk <kj@orbekk.com>2021-03-07 15:11:56 -0500
commit78529ae2641e8645ee3459753819d0ecff655d86 (patch)
tree03f2f8e25ad0decd0f6dcd0a65664a8f7a90796a /config/common.nix
parent46e1d2a1552d4aaad676faf49cb0582515d62c86 (diff)
Refactor configs into modules
Diffstat (limited to 'config/common.nix')
-rw-r--r--config/common.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/config/common.nix b/config/common.nix
deleted file mode 100644
index 09f04a7..0000000
--- a/config/common.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ config, lib, pkgs, ... }:
-{
- imports = [ ./auto-upgrade.nix ];
- programs.zsh.enable = true;
- programs.tmux.enable = true;
-
- nixpkgs.config.packageOverrides = pkgs: {
- libsignal-protocol-c = pkgs.callPackage ../pkgs/libsignal-c/default.nix { };
- keycloak = pkgs.callPackage ../pkgs/keycloak/default.nix { };
- };
-
- environment.shellAliases = {
- vim = "nvim";
- };
- environment.systemPackages = with pkgs; [
- dnsutils
- git
- gnupg
- haskellPackages.hledger
- htop
- mosh
- neovim
- # nox # Broken as of 2017-06-12
- pass
- silver-searcher
- whois
- unzip
- p7zip
- unrar
- ];
- time.timeZone = "America/New_York";
-
- system.stateVersion = "17.04";
- services = {
- postgresql = {
- dataDir = "/var/db/postgresql";
- package = pkgs.postgresql95;
- };
- openssh.passwordAuthentication = false;
- };
-
- nix = rec {
- useSandbox = lib.mkDefault true;
- maxJobs = lib.mkOverride 110 16;
- buildCores = lib.mkDefault 0; # auto configure
- gc.automatic = lib.mkDefault true;
- trustedBinaryCaches = [
- "https://cache.nixos.org"
- ];
- binaryCaches = trustedBinaryCaches;
- daemonNiceLevel = 10;
- daemonIONiceLevel = 10;
- package = pkgs.nixFlakes;
- extraOptions = ''
- experimental-features = nix-command flakes
- '';
- };
-
- boot.cleanTmpDir = true;
-
- nixpkgs.config.allowUnfree = true;
-}