summaryrefslogtreecommitdiff
path: root/nix-home-config/my-env.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-home-config/my-env.nix')
-rw-r--r--nix-home-config/my-env.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/nix-home-config/my-env.nix b/nix-home-config/my-env.nix
deleted file mode 100644
index 73ed0e7..0000000
--- a/nix-home-config/my-env.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-{ config, pkgs, ... }:
-
-{
- programs.home-manager.enable = true;
- programs.neovim.enable = true;
- services.lorri.enable = true;
-
- home.sessionVariables = {
- EDITOR = "nvim";
- };
-
- home.file.".zshrc-nix-hook".text = ''
- eval "$(direnv hook zsh)"
- '';
-
- home.packages = with pkgs; [
- direnv
- htop
- (rWrapper.override {
- packages = with rPackages; [
- data_table
- ggplot2
- hms
- viridis
- lubridate
- ];
- })
- emacs
- sqlite
- hledger
- ledger
- bwm_ng
- nix-index
- rustup
- gitFull
- gargoyle
- stow
- exa
- fzf
- zoxide
- bat
- most
-
- ripgrep
- coreutils
- fd
- clang
- ];
-}