summaryrefslogtreecommitdiff
path: root/keyboards/aurora65
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/aurora65')
-rw-r--r--keyboards/aurora65/config.h37
-rw-r--r--keyboards/aurora65/info.json3
-rw-r--r--keyboards/aurora65/rules.mk8
3 files changed, 3 insertions, 45 deletions
diff --git a/keyboards/aurora65/config.h b/keyboards/aurora65/config.h
index d3679d1365..9de3235362 100644
--- a/keyboards/aurora65/config.h
+++ b/keyboards/aurora65/config.h
@@ -17,7 +17,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#pragma once
-#include "config_common.h"
/* key matrix size */
#define MATRIX_ROWS 5
@@ -29,9 +28,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
/* COL2ROW, ROW2COL*/
#define DIODE_DIRECTION COL2ROW
-/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
-#define DEBOUNCE 5
-
/* RGB Light */
#define WS2812_PWM_DRIVER PWMD1
#define WS2812_PWM_CHANNEL 3
@@ -57,36 +53,3 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define RGBLIGHT_EFFECT_RGB_TEST
#define RGBLIGHT_EFFECT_ALTERNATING
#define RGBLIGHT_EFFECT_TWINKLE
-
-/* define if matrix has ghost (lacks anti-ghosting diodes) */
-//#define MATRIX_HAS_GHOST
-
-/* If defined, GRAVE_ESC will always act as ESC when CTRL is held.
- * This is userful for the Windows task manager shortcut (ctrl+shift+esc).
- */
-// #define GRAVE_ESC_CTRL_OVERRIDE
-
-/*
- * Force NKRO
- *
- * Force NKRO (nKey Rollover) to be enabled by default, regardless of the saved
- * state in the bootmagic EEPROM settings. (Note that NKRO must be enabled in the
- * makefile for this to work.)
- *
- * If forced on, NKRO can be disabled via magic key (default = LShift+RShift+N)
- * until the next keyboard reset.
- *
- * NKRO may prevent your keystrokes from being detected in the BIOS, but it is
- * fully operational during normal computer usage.
- *
- * For a less heavy-handed approach, enable NKRO via magic key (LShift+RShift+N)
- * or via bootmagic (hold SPACE+N while plugging in the keyboard). Once set by
- * bootmagic, NKRO mode will always be enabled until it is toggled again during a
- * power-up.
- *
- */
-//#define FORCE_NKRO
-
-/* Bootmagic Lite key configuration */
-#define BOOTMAGIC_LITE_ROW 0
-#define BOOTMAGIC_LITE_COLUMN 0
diff --git a/keyboards/aurora65/info.json b/keyboards/aurora65/info.json
index 1f7207787a..28adec5eab 100644
--- a/keyboards/aurora65/info.json
+++ b/keyboards/aurora65/info.json
@@ -8,6 +8,9 @@
"pid": "0x4136",
"device_version": "0.0.1"
},
+ "processor": "STM32F072",
+ "bootloader": "stm32-dfu",
+ "community_layouts": ["65_ansi_blocker"],
"layouts": {
"LAYOUT_65_ansi_blocker": {
"layout": [
diff --git a/keyboards/aurora65/rules.mk b/keyboards/aurora65/rules.mk
index fc545388a3..f430af42f4 100644
--- a/keyboards/aurora65/rules.mk
+++ b/keyboards/aurora65/rules.mk
@@ -1,9 +1,3 @@
-# MCU name
-MCU = STM32F072
-
-# Bootloader selection
-BOOTLOADER = stm32-dfu
-
# Wildcard to allow APM32 MCU
DFU_SUFFIX_ARGS = -v FFFF -p FFFF
@@ -25,5 +19,3 @@ BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
WS2812_DRIVER = pwm # Driver for RGB uderglow
AUDIO_ENABLE = no # Audio output
-
-LAYOUTS = 65_ansi_blocker