summaryrefslogtreecommitdiff
path: root/keyboards/aurora65
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/aurora65')
-rw-r--r--keyboards/aurora65/config.h4
-rw-r--r--keyboards/aurora65/info.json5
-rw-r--r--keyboards/aurora65/rules.mk5
3 files changed, 5 insertions, 9 deletions
diff --git a/keyboards/aurora65/config.h b/keyboards/aurora65/config.h
index fad29eeec2..956053707f 100644
--- a/keyboards/aurora65/config.h
+++ b/keyboards/aurora65/config.h
@@ -26,10 +26,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define WS2812_DMA_CHANNEL 5
#define WS2812_BYTE_ORDER WS2812_BYTE_ORDER_RGB
-#define RGBLED_NUM 36
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
#define RGBLIGHT_EFFECT_BREATHING
#define RGBLIGHT_EFFECT_RAINBOW_MOOD
#define RGBLIGHT_EFFECT_RAINBOW_SWIRL
diff --git a/keyboards/aurora65/info.json b/keyboards/aurora65/info.json
index fd03acb5bd..986732d51a 100644
--- a/keyboards/aurora65/info.json
+++ b/keyboards/aurora65/info.json
@@ -8,6 +8,11 @@
"pid": "0x4136",
"device_version": "0.0.1"
},
+ "rgblight": {
+ "saturation_steps": 8,
+ "brightness_steps": 8,
+ "led_count": 36
+ },
"ws2812": {
"pin": "B15",
"driver": "pwm"
diff --git a/keyboards/aurora65/rules.mk b/keyboards/aurora65/rules.mk
index 000ee78e21..cc9d7bb3f5 100644
--- a/keyboards/aurora65/rules.mk
+++ b/keyboards/aurora65/rules.mk
@@ -1,11 +1,6 @@
# Wildcard to allow APM32 MCU
DFU_SUFFIX_ARGS = -v FFFF -p FFFF
-# Do not put the microcontroller into power saving mode
-# when we get USB suspend event. We want it to keep updating
-# backlight effects.
-OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE
-
# Build Options
# change yes to no to disable
#