summaryrefslogtreecommitdiff
path: root/keyboards/aurora65
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/aurora65')
-rw-r--r--keyboards/aurora65/config.h22
-rw-r--r--keyboards/aurora65/info.json1
-rw-r--r--keyboards/aurora65/rules.mk2
3 files changed, 1 insertions, 24 deletions
diff --git a/keyboards/aurora65/config.h b/keyboards/aurora65/config.h
index d3679d1365..a65a4c27c6 100644
--- a/keyboards/aurora65/config.h
+++ b/keyboards/aurora65/config.h
@@ -17,7 +17,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#pragma once
-#include "config_common.h"
/* key matrix size */
#define MATRIX_ROWS 5
@@ -66,27 +65,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
// #define GRAVE_ESC_CTRL_OVERRIDE
-/*
- * Force NKRO
- *
- * Force NKRO (nKey Rollover) to be enabled by default, regardless of the saved
- * state in the bootmagic EEPROM settings. (Note that NKRO must be enabled in the
- * makefile for this to work.)
- *
- * If forced on, NKRO can be disabled via magic key (default = LShift+RShift+N)
- * until the next keyboard reset.
- *
- * NKRO may prevent your keystrokes from being detected in the BIOS, but it is
- * fully operational during normal computer usage.
- *
- * For a less heavy-handed approach, enable NKRO via magic key (LShift+RShift+N)
- * or via bootmagic (hold SPACE+N while plugging in the keyboard). Once set by
- * bootmagic, NKRO mode will always be enabled until it is toggled again during a
- * power-up.
- *
- */
-//#define FORCE_NKRO
-
/* Bootmagic Lite key configuration */
#define BOOTMAGIC_LITE_ROW 0
#define BOOTMAGIC_LITE_COLUMN 0
diff --git a/keyboards/aurora65/info.json b/keyboards/aurora65/info.json
index 1f7207787a..4c8e540720 100644
--- a/keyboards/aurora65/info.json
+++ b/keyboards/aurora65/info.json
@@ -8,6 +8,7 @@
"pid": "0x4136",
"device_version": "0.0.1"
},
+ "community_layouts": ["65_ansi_blocker"],
"layouts": {
"LAYOUT_65_ansi_blocker": {
"layout": [
diff --git a/keyboards/aurora65/rules.mk b/keyboards/aurora65/rules.mk
index fc545388a3..a53d7daeb0 100644
--- a/keyboards/aurora65/rules.mk
+++ b/keyboards/aurora65/rules.mk
@@ -25,5 +25,3 @@ BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
WS2812_DRIVER = pwm # Driver for RGB uderglow
AUDIO_ENABLE = no # Audio output
-
-LAYOUTS = 65_ansi_blocker