{ config, lib, pkgs, ... }:
{
  system.autoUpgrade = {
    enable = true;
    dates = "04:40";
    flake =
      if config.networking.hostName == "dragon" then
        "git+file:///storage/projects/nixos-config.git"
      else
        "git+https://git.orbekk.com/nixos-config.git";
  };
}