summaryrefslogtreecommitdiff
path: root/modules/vpn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/vpn.nix')
-rw-r--r--modules/vpn.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/modules/vpn.nix b/modules/vpn.nix
index b99b73e..fb6b255 100644
--- a/modules/vpn.nix
+++ b/modules/vpn.nix
@@ -48,11 +48,6 @@ in {
orbekk.vpn = {
enable = lib.mkEnableOption "Enable VPN";
- is_server = lib.mkOption {
- type = lib.types.bool;
- default = false;
- };
-
listenPort = lib.mkOption {
type = lib.types.port;
default = 40422;
@@ -76,14 +71,14 @@ in {
interfaces.vpn = {
ips = hosts.${config.networking.hostName}.ips;
privateKeyFile =
- "${config.age.secrets."${config.networking.hostName}-wireguard-key".path}";
+ "/opt/secret/wireguard/${config.networking.hostName}-wireguard-key.priv";
allowedIPsAsRoutes = true;
listenPort = cfg.listenPort;
peers = [
{
name = "dragon";
endpoint = "vpn.orbekk.com:${toString cfg.listenPort}";
- publicKey = "9q8aH3R8YBfP3xiTmN5bNiLQswY5dy3grB/P0vDqP0M=";
+ publicKey = "msfXBbmViSmxLKD3R0WrcQSRTyMrcoM67FoD7VevEn0=";
allowedIPs = ["${vpn-prefix}::/64"];
persistentKeepalive = 60;
}