summaryrefslogtreecommitdiff
path: root/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/desktop.nix')
-rw-r--r--modules/desktop.nix18
1 files changed, 7 insertions, 11 deletions
diff --git a/modules/desktop.nix b/modules/desktop.nix
index 9f0877f..9dfdadf 100644
--- a/modules/desktop.nix
+++ b/modules/desktop.nix
@@ -27,8 +27,6 @@ in {
location.latitude = 40.0;
location.longitude = -74.0;
- sound.enable = true;
-
nix.gc.automatic = true;
nix.gc.options = "--delete-older-than 30d";
@@ -47,10 +45,8 @@ in {
];
hardware = {
- opengl = {
+ graphics = {
enable = true;
- driSupport32Bit = true;
- driSupport = true;
extraPackages32 = with pkgs.pkgsi686Linux; [ libva ];
};
@@ -130,11 +126,11 @@ in {
ledger
networkmanagerapplet
nix-index
- nixfmt
+ nixfmt-rfc-style
shfmt
pavucontrol
rofi
- rxvt_unicode-with-plugins
+ rxvt-unicode
signal-desktop
sshfs-fuse
trayer
@@ -153,7 +149,7 @@ in {
xsel # used by urxvt clipboard
xss-lock
dunst
- transmission-qt
+ transmission_4-qt
qt5.qtwayland
libsForQt5.bismuth
mujmap # email sync -- get this from cargo instead
@@ -191,6 +187,9 @@ in {
};
avahi.openFirewall = true;
+ displayManager.sddm.enable = true;
+ displayManager.sessionPackages = with pkgs; [ river ];
+
xserver = {
enable = true;
xkb.layout = "us";
@@ -203,9 +202,6 @@ in {
enableContribAndExtras = true;
extraPackages = hpkgs: [ hpkgs.xmobar hpkgs.split ];
};
-
- displayManager.sddm.enable = true;
- displayManager.sessionPackages = with pkgs; [ river ];
};
};
};