summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 6dcce7c..f8b88cd 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,8 +1,10 @@
{
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.09";
inputs.nixpkgs_unstable.url = "github:NixOS/nixpkgs/nixos-unstable";
+ inputs.nix.url = "github:orbekk/nix/master";
+ inputs.nix.inputs.nixpkgs.follows = "nixpkgs";
- outputs = { self, nixpkgs, nixpkgs_unstable }:
+ outputs = { self, nixpkgs, nixpkgs_unstable, nix }:
{
nixosConfigurations = let
mkConfig = { hostName
@@ -20,9 +22,11 @@
system.configurationRevision =
if self ? rev then self.rev else "DIRTY";
- # Add unstable packages.
nixpkgs.overlays = [
+ # Add unstable packages.
(final: prev: { unstable = nixpkgs_unstable.legacyPackages."x86_64-linux"; })
+ # For git+file support with bare repo.
+ nix.overlay
];
})
];