summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d94478d..978b184 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,6 +32,16 @@
in
{
+ nixosModules = [
+ pkgs-module
+ ./modules/common.nix
+ ./modules/desktop.nix
+ ./modules/gaming.nix
+ ./modules/thinkpad.nix
+ ./modules/users.nix
+ ./modules/yubikey.nix
+ ];
+
nixosConfigurations = let
mkConfig = { hostName
, module ? (./. + "/machines/${hostName}.nix")
@@ -41,6 +51,7 @@
inherit system;
modules =
+ self.nixosModules ++
[
pkgs-module
module
@@ -50,7 +61,7 @@
# of this flake.
system.configurationRevision =
let
- lastModified = final.substring 0 8 (self.lastModifiedDate or self.lastModified or "19700101");
+ lastModified = pkgs.lib.substring 0 8 (self.lastModifiedDate or self.lastModified or "19700101");
in
"${lastModified}.${self.shortRev or "dirty"}";